LiveZilla Live Help
04.11.2017 / 07:48

Important Notice: MetaTrader 4 Updates


Dear Trader,

Metaquotes, the technology provider behind the MetaTrader 4 platform has released an updated build 1090 on May 19, 2017. The latest update is connected with the release of Windows 10 Insider Creators Update.

Clients are requested to update to the latest version of MetaTrader 4 platform for uninterrupted trading as the older versions of MT4 client terminals could occasionally face problems with running MQL4 programs in the new Windows 10 system version.

Please note that support for all MetaTrader 4 client terminal versions below 1065 will be discontinued from the October 1, 2017. Unsupported terminal builds will not be able to connect to servers.

We would also like to inform you that from October 1, 2017, MetaQuotes has discontinued its support for the MetaTrader platforms on the Windows XP, Windows 2003 and Windows Vista operating systems.

The minimum system requirements for MetaTrader 4 after this date is Windows 7, although we highly recommend that you use the 64-bit version of Windows 10 to fully benefit from the latest updates and support.

You can find the following MetaTrader4 versions on the EuromaxFX website:

MetaTrader 4 for PC Windows

MetaTrader 4 for Android

MetaTrader 4 for iOS

If you have any questions or require any assistance, please contact our support team members via Live Chat or email: support@euromaxfx.com.

Regards,

EUROMAX COMMERCIAL CORP.